gradle项目与maven项目互转

maven to gradle

在maven项目根目录下执行命令:

gradle init --type pom
当然你得先下载Gradle,配置完环境变量。

gradle to maven 

gradle.build必须如下配置:

1apply plugin: 'java' 2apply plugin: 'maven' 3 4group = 'xxx.xxx' 5version = '1.0-SNAPSHOT' 6 7dependencies { 8compile 'commons-lang:commons-lang:2.3' 9} 10

在Gradle项目根目录下执行 gradle install,我们会发现根目录的build文件夹下生成了一个poms文件夹,里面包含我们需要的pom文件。

使用maven的mvn compile编译过程中,出现如下警告:

[WARNING] File encoding has not been set, using platform encoding GBK, i.e. build is platform dependent!

解决:在pom.xml文件中配置:

1<properties> 2 <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding> 3</properties> 4

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project SM: Compilation failure: Compilation failure:
[ERROR] /D:/N3verL4nd/Desktop/maven/src/main/java/com/xiya/dao/UserDao.java:[17,30] -source 1.5 中不支持 diamond 运算符
[ERROR] (请使用 -source 7 或更高版本以启用 diamond 运算符)
[ERROR] /D:/N3verL4nd/Desktop/maven/src/main/java/com/xiya/controller/TestController.java:[21,41] -source 1.5 中不支持 diamond 运算符
[ERROR] (请使用 -source 7 或更高版本以启用 diamond 运算符)
[ERROR] -> [Help 1]

 

 

根据提示,我们需要指定较高的JDK版本

 

设置(全局):\apache-maven-3.3.9\conf\settings.xml

1<profile> 2 <id>jdk18</id> 3 <activation> 4 <activeByDefault>true</activeByDefault> 5 <jdk>1.8</jdk> 6 </activation> 7 <properties> 8 <maven.compiler.source>1.8</maven.compiler.source> 9 <maven.compiler.target>1.8</maven.compiler.target> 10 <maven.compiler.compilerVersion>1.8</maven.compiler.compilerVersion> 11 </properties> 12</profile> 13

再次执行,就不报错了 

代码交流 2021